{"id":"CVE-2011-0446","published":"2011-02-14T20:00:00Z","modified":"2024-08-06T21:51:09Z","title":"Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x…","vendor":null,"product":null,"tier":"tail","description":{"text":"Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.","provenance":"source","from":"CVE.org"},"cvss":null,"epss":{"score":0.0235,"percentile":0.83573,"provenance":"source"},"cwes":[],"references":[{"url":"http://www.vupen.com/english/advisories/2011/0587","tags":["vdb-entry","x_refsource_VUPEN"]},{"url":"http://lists.fedoraproject.org/pipermail/package-announce/2011-March/055088.html","tags":["vendor-advisory","x_refsource_FEDORA"]},{"url":"http://www.securityfocus.com/bid/46291","tags":["vdb-entry","x_refsource_BID"]},{"url":"http://www.debian.org/security/2011/dsa-2247","tags":["vendor-advisory","x_refsource_DEBIAN"]},{"url":"http://lists.fedoraproject.org/pipermail/package-announce/2011-April/057650.html","tags":["vendor-advisory","x_refsource_FEDORA"]},{"url":"http://secunia.com/advisories/43274","tags":["third-party-advisory","x_refsource_SECUNIA"]},{"url":"http://www.securitytracker.com/id?1025064","tags":["vdb-entry","x_refsource_SECTRACK"]},{"url":"http://groups.google.com/group/rubyonrails-security/msg/365b8a23b76a6b4a?dmode=source&output=gplain","tags":["mailing-list","x_refsource_MLIST"]},{"url":"http://www.vupen.com/english/advisories/2011/0877","tags":["vdb-entry","x_refsource_VUPEN"]},{"url":"http://lists.fedoraproject.org/pipermail/package-announce/2011-March/055074.html","tags":["vendor-advisory","x_refsource_FEDORA"]},{"url":"http://secunia.com/advisories/43666","tags":["third-party-advisory","x_refsource_SECUNIA"]}],"priority":{"score":16.7,"factors":[{"name":"EPSS percentile","points":16.71}]},"affected":[{"ecosystem":"RubyGems","package":"actionpack","vulnerableRanges":["<2.3.11",">=3.0.0, <3.0.4"],"patched":["2.3.11","3.0.4"],"from":["GHSA-75w6-p6mg-vh8j"],"provenance":"source"},{"ecosystem":"RubyGems","package":"actionview","vulnerableRanges":["<2.3.11",">=3.0.0, <3.0.4"],"patched":["2.3.11","3.0.4"],"from":["GHSA-75w6-p6mg-vh8j"],"provenance":"source"}],"euvd":{"id":"EUVD-2017-0182","exploited":false,"provenance":"source"}}