{"id":"CVE-2026-54163","published":"2026-07-17T20:19:18Z","modified":"2026-07-20T17:45:49Z","title":"secure_headers: CSP directive injection via sandbox, plugin_types, and report_to when given untrusted input","vendor":"GitHub","product":"secure_headers","tier":"tail","description":{"text":"secure_headers manages application of security headers with many safe defaults. Prior to 7.3.0, secure_headers builds the Content-Security-Policy value by stitching directives with ; separators, and build_sandbox_list_directive, build_media_type_list_directive, and build_report_to_directive interpolate caller-supplied strings without scrubbing ;, \\r, or \\n. When untrusted input reaches SecureHeaders.override_content_security_policy_directives or append APIs for :sandbox, :plugin_types, or :report_to, an attacker can inject a CSP directive such as script-src 'unsafe-inline' * before the legitimate script-src, enabling XSS reachability through these sinks or CSP report exfiltration. This issue is fixed in version 7.3.0.","provenance":"source","from":"CVE.org"},"cvss":{"score":4.7,"severity":"MEDIUM","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N","provenance":"source","from":"CVE.org CNA"},"epss":{"score":0.00214,"percentile":0.11707,"provenance":"source"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-113","name":"Improper Neutralization of CRLF Sequences in HTTP Headers"}],"references":[{"url":"https://github.com/github/secure_headers/security/advisories/GHSA-rqq5-2gf9-4w4q","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/github/secure_headers/commit/286a79dea80c6a9be4ca93e0f284c923cf77e539","tags":["x_refsource_MISC"]},{"url":"https://github.com/github/secure_headers/releases/tag/v7.3.0","tags":["x_refsource_MISC"]}],"priority":{"score":5.6,"factors":[{"name":"EPSS percentile","points":2.34},{"name":"CVSS severity","points":3.29}]},"vendorSlug":"github","affectedVersions":[{"vendor":"github","product":"secure_headers","versions":["< 7.3.0"]}],"affected":[{"ecosystem":"RubyGems","package":"secure_headers","vulnerableRanges":["<7.3.0"],"patched":["7.3.0"],"from":["GHSA-rqq5-2gf9-4w4q"],"provenance":"source"}],"euvd":{"id":"EUVD-2026-45317","exploited":false,"provenance":"source"}}