Patchfirst
CVE-2008-1232 Public exploit EPSS 75.9%

Cross-site scripting (XSS) vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0…

Summary

The flaw is a cross-site scripting (XSS) vulnerability in Apache Tomcat, affecting versions 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, where the message argument passed to the HttpServletResponse.sendError method is not properly sanitised. A remote attacker who supplies a crafted string as that message can inject arbitrary web script or HTML into the response.

Official description · CVE.org

Cross-site scripting (XSS) vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16 allows remote attackers to inject arbitrary web script or HTML via a crafted string that is used in the message argument to the HttpServletResponse.sendError method.

Breakdown
24.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Exploit-DB) was available 3 days before disclosure.

  1. Public exploit codeExploit-DB3 days before
  2. Disclosedday 0

7 fixes in tomcat over 14 months. The latest fix listed for tomcat is 6.0.18.

Fixes in tomcatMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 6.0.14CVE-2007-245014 Jun 2007
  2. 6.0.15CVE-2007-533312 Feb 2008
  3. 6.0.16CVE-2008-000212 Feb 2008
  4. 6.0.17CVE-2008-12324 Aug 2008
  5. 6.0.18CVE-2008-19474 Jun 2008
  6. 6.0.18CVE-2008-23704 Aug 2008
  7. 6.0.18CVE-2008-293813 Aug 2008Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.tomcat:tomcat.

Mavenorg.apache.tomcat:tomcatGHSA-q74x-qqhr-f8rx

Upgrade to 6.0.35 or later

Fixes this CVE and 8 other known vulnerabilities in this package (CVE-2007-0450, CVE-2007-2449, +6).

Set the version to 6.0.35 or later in your pom.xml or build.gradle.

First fixed in 6.0.17 for CVE-2008-1232.

Affected versions, by release line

If you runUpgrade to
6.0.0 up to 6.0.176.0.35first fix for this CVE: 6.0.17
5.5.0 up to 5.5.275.5.35first fix for this CVE: 5.5.27
4.1.0 up to 4.1.384.1.40first fix for this CVE: 4.1.38

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

64 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close