Patchfirst
CVE-2009-0580 Public exploit EPSS 94.4%

Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18, when FORM authentication is used…

Summary

Apache Tomcat versions 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 contain improper error checking in the MemoryRealm, DataSourceRealm, and JDBCRealm authentication realms when FORM authentication is used. A remote attacker who can send requests to /j_security_check can enumerate valid usernames by submitting malformed URL encoding in the j_password parameter, such as a lone % character, without needing prior authentication.

Official description · CVE.org

Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18, when FORM authentication is used, allows remote attackers to enumerate valid usernames via requests to /j_security_check with malformed URL encoding of passwords, related to improper error checking in the (1) MemoryRealm, (2) DataSourceRealm, and (3) JDBCRealm authentication realms, as demonstrated by a % (percent) value for the j_password parameter.

Breakdown
25.0 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Exploit-DB) was available 2 days before disclosure.

  1. Public exploit codeExploit-DB2 days before
  2. Disclosedday 0

7 fixes in tomcat over 12 months. The latest fix listed for tomcat is 6.0.20.

Fixes in tomcatMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 6.0.18CVE-2008-19474 Jun 2008
  2. 6.0.18CVE-2008-23704 Aug 2008
  3. 6.0.18CVE-2008-293813 Aug 2008
  4. 6.0.19CVE-2009-05805 Jun 2009
  5. 6.0.20CVE-2009-07819 Mar 2009
  6. 6.0.20CVE-2009-07835 Jun 2009
  7. 6.0.20CVE-2008-551516 Jun 2009Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.tomcat:tomcat.

Mavenorg.apache.tomcat:tomcatGHSA-w227-xcfx-3pj8

Upgrade to 6.0.35 or later

Fixes this CVE and 8 other known vulnerabilities in this package (CVE-2007-0450, CVE-2007-2449, +6).

Set the version to 6.0.35 or later in your pom.xml or build.gradle.

First fixed in 6.0.19 for CVE-2009-0580.

Affected versions, by release line

If you runUpgrade to
6.0.0 up to 6.0.196.0.35first fix for this CVE: 6.0.19
5.0.0 up to 5.5.285.5.35first fix for this CVE: 5.5.28
4.1.0 up to 4.1.404.1.40

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

49 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close