Patchfirst
CVE-2011-3923 Public exploit EPSS 89.5%

Apache Struts before 2.3.1.2 allows remote attackers to bypass security protections in the ParameterInterceptor class and execute arbitrary commands.

Apache · Struts

Summary

The flaw is in the ParameterInterceptor class of Apache Struts, in versions before 2.3.1.2, where security protections can be bypassed.

Heading is the official description · CVE.org
Breakdown
25.0 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Metasploit) was available 8 years before disclosure.

  1. Public exploit codeMetasploit8 yrs before
  2. Disclosedday 0

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.struts:struts2-core.

Mavenorg.apache.struts:struts2-coreGHSA-j68f-8h6p-9h5q

Upgrade to 2.5.33

Fixes this CVE and 23 other known vulnerabilities in this package (CVE-2008-6505, CVE-2010-1870, +21).

Still affected on this line by CVE-2024-53677 (fixed in 6.4.0, a newer line); CVE-2025-68493 (no fix published).

Set the version to 2.5.33 or later in your pom.xml or build.gradle.

First fixed in 2.3.1.2 for CVE-2011-3923.

Affected versions

If you runUpgrade to
2.0.0 up to 2.3.1.22.5.33first fix for this CVE: 2.3.1.2

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

7 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close