Upgrade to 2.5.33
Fixes this CVE and 23 other known vulnerabilities in this package (CVE-2008-6505, CVE-2010-1870, +21).
Still affected on this line by CVE-2024-53677 (fixed in 6.4.0, a newer line); CVE-2025-68493 (no fix published).
Set the version to 2.5.33 or later in your pom.xml or build.gradle.
First fixed in 2.3.20 for CVE-2014-0113.
Affected versions
| If you run | Upgrade to |
|---|---|
| All versions before 2.3.20 | 2.5.33first fix for this CVE: 2.3.20 |
“Up to” means the second version is the fix and is not affected.