Patchfirst
CVE-2015-1830 Public exploit EPSS 84.4%

Directory traversal vulnerability in the fileserver upload/download functionality for blob messages in Apache ActiveMQ…

Summary

A directory traversal flaw exists in the fileserver upload and download functionality for blob messages in Apache ActiveMQ 5.x before 5.11.2 on Windows. An attacker with remote access, through unspecified vectors, can create JSP files in arbitrary directories.

Official description · CVE.org

Directory traversal vulnerability in the fileserver upload/download functionality for blob messages in Apache ActiveMQ 5.x before 5.11.2 for Windows allows remote attackers to create JSP files in arbitrary directories via unspecified vectors.

Breakdown
24.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Exploit-DB) was available 2 days before disclosure.

  1. Public exploit codeExploit-DB2 days before
  2. Disclosedday 0

See the family tree

2 related vulnerabilities in the same code over 9 months. The latest fix listed for activemq-client is 5.13.2.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. This CVECVE-2015-1830Directory traversal vulnerability in the fileserver…19 Aug 2015
  2. relatedMedium

    Why these are linked:

    CVE-2016-3088ActiveMQ Improper Input Validation1 Jun 2016KEV

Fixes in activemq-clientMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 5.10.1CVE-2014-811012 Feb 2015
  2. 5.10.1CVE-2014-360027 Oct 2017
  3. 5.11.0CVE-2014-357614 Aug 2015
  4. 5.11.2CVE-2015-183019 Aug 2015
  5. 5.12.2CVE-2015-52548 Jan 2016
  6. 5.13.2CVE-2016-07347 Apr 2016
  7. 5.13.2CVE-2016-07825 Aug 2016Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.activemq:activemq-client.

Mavenorg.apache.activemq:activemq-clientGHSA-3v63-f83x-37x4

Upgrade to 5.15.16 or later

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2016-3088, CVE-2023-46604).

Set the version to 5.15.16 or later in your pom.xml or build.gradle.

First fixed in 5.11.2 for CVE-2015-1830.

Affected versions

If you runUpgrade to
5.0.0 up to 5.11.25.15.16first fix for this CVE: 5.11.2

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

6 links, grouped by NVD tag (1 duplicate merged)
↑ ↓ chooseEnter openEsc close