Patchfirst
CVE-2015-5531 Public exploit EPSS 94.8%

Directory traversal vulnerability in Elasticsearch before 1.6.1 allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls.

Summary

The flaw is a directory traversal vulnerability in Elasticsearch versions before 1.6.1, located in the handling of snapshot API calls. An attacker who can reach the affected service over the network can read arbitrary files on the host through unspecified request vectors.

Heading is the official description · CVE.org
Breakdown
61.1 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 10 years after disclosure. Public exploit code (Exploit-DB) appeared 46 days after disclosure.

  1. Disclosedday 0
  2. Public exploit codeExploit-DB+46 days
  3. First seen exploitedVulnCheck KEV evidence+10 yrs

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.elasticsearch:elasticsearch.

Mavenorg.elasticsearch:elasticsearchGHSA-jjq8-vfjq-j6v4

Upgrade to 1.6.1 or later

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2014-3120, CVE-2015-1427).

Set the version to 1.6.1 or later in your pom.xml or build.gradle.

The first fix for CVE-2015-5531.

Affected versions

If you runUpgrade to
All versions before 1.6.11.6.1

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 2 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

7 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close