Upgrade to 1.650
Still affected on this line by CVE-2016-9299 (fixed in 2.19.3, a newer line); CVE-2017-1000353 (fixed in 2.46.2, a newer line); CVE-2018-1000861 (fixed in 2.138.4, a newer line); CVE-2018-1999002 (fixed in 2.121.2, a newer line); CVE-2019-10405 (fixed in 2.176.4, a newer line); CVE-2020-2230 (fixed in 2.235.4, a newer line); CVE-2024-23897 (fixed in 2.426.3, a newer line); CVE-2025-59474 (fixed in 2.516.3, a newer line); CVE-2026-53435 (fixed in 2.555.3, a newer line).
Set the version to 1.650 or later in your pom.xml or build.gradle.
The first fix for CVE-2016-0792.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 1.643 up to 1.650 | 1.650 |
| All versions before 1.642.2 Still affected on this line by CVE-2016-9299 (fixed in 2.19.3, a newer line); CVE-2017-1000353 (fixed in 2.46.2, a newer line); CVE-2018-1000861 (fixed in 2.138.4, a newer line); CVE-2018-1999002 (fixed in 2.121.2, a newer line); CVE-2019-10405 (fixed in 2.176.4, a newer line); CVE-2020-2230 (fixed in 2.235.4, a newer line); CVE-2024-23897 (fixed in 2.426.3, a newer line); CVE-2025-59474 (fixed in 2.516.3, a newer line); CVE-2026-53435 (fixed in 2.555.3, a newer line). | 1.642.2 |
“Up to” means the second version is the fix and is not affected.