Patchfirst
CVE-2016-10045 Public exploit EPSS 97.7%

The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail…

Summary

The isMail transport in PHPMailer before 5.2.20 has a flaw in how it passes parameters to the mail command, stemming from an incorrect fix for an earlier issue. Remote attackers can exploit improper interaction between the escapeshellarg function and the internal escaping performed by PHP's mail function to inject extra parameters and execute arbitrary code.

Official description · CVE.org

The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code by leveraging improper interaction between the escapeshellarg function and internal escaping performed in the mail function in PHP. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-10033.

Breakdown
25.0 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Metasploit) was available 4 days before disclosure.

  1. Public exploit codeMetasploit4 days before
  2. Disclosedday 0

See the family tree

A fix was bypassed or incomplete once on the same day. The latest fix listed for phpmailer/phpmailer is 6.0.6.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2016-10033PHPMailer Command Injection30 Dec 2016KEV
  2. incomplete fixHigh

    Why these are linked:

    • Stated in the CVE textNOTE: this vulnerability exists because of an incorrect fix for CVE-2016-10033.
    • Fixed one release later5.2.18 → 5.2.20 (phpmailer/phpmailer)
    • Similar weakness in the same product (machine-matched)same package + description similarity
    This CVECVE-2016-10045The isMail transport in PHPMailer before 5.2.20 might allow…30 Dec 2016

Fixes in phpmailer/phpmailerPackagist package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 5.2.10CVE-2008-561917 Dec 2008
  2. 5.2.14CVE-2015-847616 Dec 2015
  3. 5.2.18CVE-2016-1003330 Dec 2016KEV
  4. 5.2.20CVE-2016-1004530 Dec 2016
  5. 5.2.22CVE-2017-522316 Jan 2017
  6. 5.2.24CVE-2017-1150320 Jul 2017
  7. 6.0.6CVE-2018-1929616 Nov 2018Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: phpmailer/phpmailer.

Packagistphpmailer/phpmailerGHSA-4pc3-96mx-wwc8

Upgrade to 5.2.20 or later

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2008-5619, CVE-2016-10033).

Set the version to 5.2.20 or later in your composer.json.

The first fix for CVE-2016-10045.

Affected versions

If you runUpgrade to
5.0.0 up to 5.2.205.2.20

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

15 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close