Patchfirst
CVE-2019-0568 Public exploit EPSS 69.5%

A remote code execution vulnerability exists in the way that the Chakra scripting engine handles objects in memory in…

Microsoft · Microsoft Edge

Summary

A remote code execution flaw in Microsoft Edge's Chakra scripting engine stems from how the engine handles objects in memory, resulting in a memory corruption vulnerability that also affects ChakraCore. An attacker could execute arbitrary code by exploiting this memory handling flaw; the available record does not specify the required access, authentication, or user interaction conditions.

Official description · CVE.org

A remote code execution vulnerability exists in the way that the Chakra scripting engine handles objects in memory in Microsoft Edge, aka "Chakra Scripting Engine Memory Corruption Vulnerability." This affects Microsoft Edge, ChakraCore. This CVE ID is unique from CVE-2019-0539, CVE-2019-0567.

Breakdown
25.6 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Exploit-DB) appeared 10 days after disclosure. No confirmed exploitation is recorded.

  1. Disclosedday 0
  2. Public exploit codeExploit-DB+10 days

8 fixes in Microsoft.ChakraCore over 4 months. The latest fix listed for Microsoft.ChakraCore is 1.11.7.

Fixes in Microsoft.ChakraCoreNuGet package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.11.4CVE-2018-861812 Dec 2018
  2. 1.11.4CVE-2018-862912 Dec 2018
  3. 1.11.5CVE-2019-05398 Jan 2019
  4. 1.11.5CVE-2019-05678 Jan 2019
  5. 1.11.5CVE-2019-05688 Jan 2019
  6. 1.11.6CVE-2019-06486 Mar 2019
  7. 1.11.6CVE-2019-06496 Mar 2019
  8. 1.11.7CVE-2019-05928 Apr 2019Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: Microsoft.ChakraCore.

NuGetMicrosoft.ChakraCoreGHSA-2m5h-6g38-jjf2

Upgrade to 1.11.11 or later

Fixes this CVE and 44 other known vulnerabilities in this package (CVE-2016-0191, CVE-2016-0193, +42).

Set the version to 1.11.11 or later in your .csproj.

First fixed in 1.11.5 for CVE-2019-0568.

Affected versions

If you runUpgrade to
All versions before 1.11.51.11.11first fix for this CVE: 1.11.5

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 1 community threat pulse (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close