Patchfirst
CVE-2019-1003001 Public exploit EPSS 86.1%

A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in…

Jenkins project · Pipeline: Groovy Plugin

Summary

A sandbox bypass in the Pipeline: Groovy Plugin for Jenkins, in the CpsFlowDefinition.java and CpsGroovyShellFactory.java components, is the flaw. An attacker holding Overall/Read permission can submit a pipeline script to an HTTP endpoint and execute arbitrary code on the Jenkins master JVM.

Official description · CVE.org

A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in src/main/java/org/jenkinsci/plugins/workflow/cps/CpsFlowDefinition.java, src/main/java/org/jenkinsci/plugins/workflow/cps/CpsGroovyShellFactory.java that allows attackers with Overall/Read permission to provide a pipeline script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.

Breakdown
61.5 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 5 years after disclosure. Public exploit code (Metasploit) was available 14 days before disclosure.

  1. Public exploit codeMetasploit14 days before
  2. Disclosedday 0
  3. First seen exploitedVulnCheck KEV evidence+5 yrs

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

3 packages in 1 ecosystem. Main package: org.jenkins-ci.plugins:pipeline-model-definition.

Mavenorg.jenkins-ci.plugins:pipeline-model-definitionGHSA-6q78-6xvr-26fg

Upgrade to 1.3.4.1 or later

Set the version to 1.3.4.1 or later in your pom.xml or build.gradle.

The first fix for CVE-2019-1003001. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 1.3.4.11.3.4.1

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (2)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • Mavenorg.jenkins-ci.plugins.workflow:workflow-cps-parent
    Affected: All versions before 2.61.1Upgrade to 2.61.1 or later
  • Mavenorg.jenkins-ci.plugins:script-security
    Affected: All versions before 1.50Upgrade to 1.54 or later

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 4 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

6 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close