Patchfirst
CVE-2019-16768 Low · 3.5 EPSS 0.7%

Internal exception message exposure for login action in Sylius

Sylius · Sylius

Official description · CVE.org

In affected versions of Sylius, exception messages from internal exceptions (like database exception) are wrapped by \Symfony\Component\Security\Core\Exception\AuthenticationServiceException and propagated through the system to UI. Therefore, some internal system information may leak and be visible to the customer. A validation message with the exception details will be presented to the user when one will try to log into the shop. This has been patched in versions 1.3.14, 1.4.10, 1.5.7, and 1.6.3.

Breakdown
13.4 / 100
Exploited
Not confirmed
Reports
0
Tactics
1/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. What they do

Disclosed on 5 Dec 2019. No public exploit code or confirmed exploitation is recorded.

6 fixes in sylius/sylius over 19 months. The latest fix listed for sylius/sylius is 1.9.5.

Fixes in sylius/syliusPackagist package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.4.4CVE-2019-1218631 Dec 2019
  2. 1.4.4CVE-2020-522027 Jan 2020
  3. 1.6.3CVE-2019-167685 Dec 2019
  4. 1.6.5CVE-2020-521827 Jan 2020
  5. 1.8.3CVE-2020-1524519 Oct 2020
  6. 1.9.5CVE-2021-3272028 Jun 2021Latest listed

techniques

1 , grouped by in kill-chain order 1

CollectionTA0009

MITRE CTID mapping of the CVE · primary impact

Detection

0 rules for this CVE · 14 general rules for its techniques

Rules for this CVE

0 that reference CVE-2019-16768 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: sylius/sylius.

Packagistsylius/syliusGHSA-3r8j-pmch-5j2h

Upgrade to 1.6.3 or later

Set the version to 1.6.3 or later in your composer.json.

The first fix for CVE-2019-16768.

Affected versions, by release line

If you runUpgrade to
1.6.0 up to 1.6.31.6.3
1.5.0 up to 1.5.71.5.7
1.4.0 up to 1.4.101.4.10
All versions before 1.3.141.3.14

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close