Patchfirst
CVE-2019-17564 Public exploit EPSS 36.5%

Unsafe deserialization occurs within a Dubbo application which has HTTP remoting enabled

Apache · Apache Dubbo

Official description · CVE.org

Unsafe deserialization occurs within a Dubbo application which has HTTP remoting enabled. An attacker may submit a POST request with a Java object in it to completely compromise a Provider instance of Apache Dubbo, if this instance enables HTTP. This issue affected Apache Dubbo 2.7.0 to 2.7.4, 2.6.0 to 2.6.7, and all 2.5.x versions.

Breakdown
60.4 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 4 years after disclosure. Public exploit code (PoC-in-GitHub) was available 48 days before disclosure.

  1. Public exploit codePoC-in-GitHub48 days before
  2. Disclosedday 0
  3. First seen exploitedVulnCheck KEV evidence+4 yrs

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.dubbo:dubbo-rpc-http-invoker.

Mavenorg.apache.dubbo:dubbo-rpc-http-invokerGHSA-69wp-3pm3-hxgg

Upgrade to 2.7.5 or later

Set the version to 2.7.5 or later in your pom.xml or build.gradle.

The first fix for CVE-2019-17564. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
2.5.0 up to 2.7.52.7.5

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 1 community threat pulse (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close