Patchfirst
CVE-2020-11975 Public exploit EPSS 30.6%

Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

Heading is the official description · CVE.org
Breakdown
59.6 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 10 months after disclosure. Public exploit code (PoC-in-GitHub) appeared 6 months after disclosure.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+6 mo
  3. First seen exploitedVulnCheck KEV evidence+10 mo

3 fixes in unomi over 11 months. The latest fix listed for unomi is 1.5.5.

Fixes in unomiMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.5.2CVE-2020-1394224 Nov 2020
  2. 1.5.4CVE-2020-119755 Jun 2020
  3. 1.5.5CVE-2021-311644 May 2021Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.unomi:unomi.

Mavenorg.apache.unomi:unomiGHSA-v6fq-q792-j46j

Upgrade to 1.5.4 or later

Fixes this CVE and 1 other known vulnerability in this package (CVE-2020-13942).

Set the version to 1.5.4 or later in your pom.xml or build.gradle.

The first fix for CVE-2020-11975.

Affected versions

If you runUpgrade to
All versions before 1.5.41.5.4

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close