Patchfirst
CVE-2020-15094 High · 8.0 EPSS 3.0%

RCE in Symfony

symfony · symfony

Official description · CVE.org

In Symfony before versions 4.4.13 and 5.1.5, the CachingHttpClient class from the HttpClient Symfony component relies on the HttpCache class to handle requests. HttpCache uses internal headers like X-Body-Eval and X-Body-File to control the restoration of cached responses. The class was initially written with surrogate caching and ESI support in mind (all HTTP calls come from a trusted backend in that scenario). But when used by CachingHttpClient and if an attacker can control the response for a request being made by the CachingHttpClient, remote code execution is possible. This has been fixed in versions 4.4.13 and 5.1.5.

Breakdown
23.1 / 100
Exploited
Not confirmed
Reports
0
Tactics
3/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. How attackers get in

  2. What they do

Disclosed on 2 Sep 2020. No public exploit code or confirmed exploitation is recorded.

techniques

2 , grouped by in kill-chain order 2

ExecutionTA0002

MITRE CTID mapping of the CVE · primary impact

Credential AccessTA0006

Network Sniffing T1040 also Discovery
MITRE CTID mapping of the CVE · how it is exploited

Detection

0 rules for this CVE · 104 general rules for its techniques

Rules for this CVE

0 that reference CVE-2020-15094 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

2 packages in 1 ecosystem. Main package: symfony/symfony.

Packagistsymfony/symfonyGHSA-754h-5r27-7x3r

Upgrade to 5.1.5 or later

Set the version to 5.1.5 or later in your composer.json.

The first fix for CVE-2020-15094.

Affected versions, by release line

If you runUpgrade to
5.0.0 up to 5.1.55.1.5
4.3.0 up to 4.4.134.4.13

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (1)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • Packagistsymfony/http-kernel
    Affected: 5.0.0 up to 5.1.5; 4.3.0 up to 4.4.13Upgrade to 5.1.5 or later (older lines: 4.4.13)

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

6 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close