Patchfirst
CVE-2020-15148 Public exploit High · 8.9 EPSS 77.5%

Unsafe deserialization in Yii 2

yiisoft · yii2

Summary

Unsafe deserialization in the Yii 2 PHP framework (yiisoft/yii2, the yii2 product from yiisoft) affects versions before 2.0.38 and lives in the application's handling of serialized data. An attacker who can supply arbitrary input that the application passes to unserialize() can achieve remote code execution, though the attack is conditional on the application actually calling unserialize() on that untrusted input and on the attacker reaching it over the network without authentication or user interaction.

Official description · CVE.org

Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input. This is fixed in version 2.0.38. A possible workaround without upgrading is available in the linked advisory.

Breakdown
31.1 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (PoC-in-GitHub) appeared 6 days after disclosure. No confirmed exploitation is recorded.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+6 days

7 fixes in yiisoft/yii2 over 7 years. The latest fix listed for yiisoft/yii2 is 2.0.52.

Fixes in yiisoft/yii2Packagist package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 2.0.14CVE-2018-600922 Jan 2018
  2. 2.0.14CVE-2018-601022 Jan 2018
  3. 2.0.16CVE-2018-2074528 Jan 2019
  4. 2.0.38CVE-2020-1514815 Sep 2020
  5. 2.0.49.4CVE-2024-3287730 May 2024
  6. 2.0.49.4CVE-2024-499020 Mar 2025
  7. 2.0.52CVE-2024-5813610 Apr 2025KEVLatest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: yiisoft/yii2.

Packagistyiisoft/yii2GHSA-699q-wcff-g9mj

Upgrade to 2.0.52 or later

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2024-4990, CVE-2024-58136).

Set the version to 2.0.52 or later in your composer.json.

First fixed in 2.0.38 for CVE-2020-15148.

Affected versions

If you runUpgrade to
All versions before 2.0.382.0.52first fix for this CVE: 2.0.38

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close