Patchfirst
CVE-2021-21029 Medium · 4.8 EPSS 84.6%

Magento Commerce Reflected Cross-site Scripting Vulnerability Could Lead To Arbitrary JavaScript Execution

Adobe · Magento Commerce

Summary

Adobe Magento Commerce contains a Reflected Cross-site Scripting flaw in its handling of the 'file' parameter, affecting Magento versions 2.4.1 and earlier, 2.4.0-p1 and earlier, and 2.3.6 and earlier. An attacker can get arbitrary JavaScript to run in a victim's browser, which requires the attacker to have admin console access and the victim to interact with a crafted link or request.

Official description · CVE.org

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting vulnerability via 'file' parameter. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.

Breakdown
23.3 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 11 Feb 2021. No public exploit code or confirmed exploitation is recorded.

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: magento/community-edition.

Packagistmagento/community-editionGHSA-jwxh-wj79-ccm6

Upgrade to 2.4.5

Fixes this CVE and 5 other known vulnerabilities in this package (CVE-2022-24086, CVE-2022-34258, +3).

Still affected on this line by CVE-2025-54236 (no fix published).

Set the version to 2.4.5 or later in your composer.json.

First fixed in 2.4.2 for CVE-2021-21029.

Affected versions, by release line

If you runUpgrade to
2.4.0 up to 2.4.22.4.5first fix for this CVE: 2.4.2
All versions before 2.3.6-p1

Still affected on this line by CVE-2024-34102 (fixed in 2.4.4-p9, a newer line); CVE-2025-54236 (no fix published).

2.3.7-p4first fix for this CVE: 2.3.6-p1

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close