Patchfirst
CVE-2021-21618 EPSS 79.5%

Jenkins Repository Connector Plugin 2.0.2 and earlier does not escape parameter names and descriptions for past…

Jenkins project · Jenkins Repository Connector Plugin

Summary

The Jenkins Repository Connector Plugin, version 2.0.2 and earlier, does not escape parameter names and descriptions shown for past builds, leaving a stored cross-site scripting flaw in the plugin's build-history display. An attacker who holds the Item/Configure permission can plant malicious script in those parameter fields, and it executes in the browser of users who later view the affected build pages.

Official description · CVE.org

Jenkins Repository Connector Plugin 2.0.2 and earlier does not escape parameter names and descriptions for past builds, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Breakdown
19.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 24 Feb 2021. No public exploit code or confirmed exploitation is recorded.

3 fixes in repository-connector over 24 months. The latest fix listed for repository-connector is 2.0.3.

Fixes in repository-connectorMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.2.5CVE-2019-10030388 Mar 2019
  2. 2.0.0CVE-2020-21499 Mar 2020
  3. 2.0.3CVE-2021-2161824 Feb 2021Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.jenkins-ci.plugins:repository-connector.

Mavenorg.jenkins-ci.plugins:repository-connectorGHSA-hg2w-3c4j-jjwm

Upgrade to 2.0.3 or later

Set the version to 2.0.3 or later in your pom.xml or build.gradle.

The first fix for CVE-2021-21618. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 2.0.32.0.3

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close