Upgrade to 2.17.1 or later
Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2021-44228, CVE-2021-44832, +1).
Set the version to 2.17.1 or later in your pom.xml or build.gradle.
First fixed in 2.17.0 for CVE-2021-45105.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 2.13.0 up to 2.17.0 | 2.17.1first fix for this CVE: 2.17.0 |
| 2.4.0 up to 2.12.3 | 2.12.4first fix for this CVE: 2.12.3 |
| All versions before 2.3.1 Still affected on this line by CVE-2017-5645 (fixed in 2.8.2, a newer line). | 2.3.2first fix for this CVE: 2.3.1 |
“Up to” means the second version is the fix and is not affected.