Patchfirst
CVE-2022-34176 EPSS 77.5%

Jenkins JUnit Plugin 1119.va_a_5e9068da_d7 and earlier does not escape descriptions of test results, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission.

Jenkins project · Jenkins JUnit Plugin

Summary

The Jenkins JUnit Plugin fails to escape descriptions of test results, creating a stored cross-site scripting flaw in the plugin's test result handling. An attacker holding Run/Update permission can exploit it by planting script content in those descriptions, which then executes in the browser of other users who view the results.

Heading is the official description · CVE.org
Breakdown
19.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 22 Jun 2022. No public exploit code or confirmed exploitation is recorded.

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.jenkins-ci.plugins:junit.

Mavenorg.jenkins-ci.plugins:junitGHSA-64mj-3p92-589v

Upgrade to 1119.1121.vc43d0fc45561 or later

Set the version to 1119.1121.vc43d0fc45561 or later in your pom.xml or build.gradle.

The first fix for CVE-2022-34176. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 1119.1121.vc43d0fc455611119.1121.vc43d0fc45561

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close