Patchfirst
CVE-2022-36096 High · 8.9 EPSS 60.2%

XWiki Platform vulnerable to Cross-site Scripting in the deleted attachments list

xwiki · xwiki-platform

Summary

A cross-site scripting flaw in the deleted attachments list of the Index UI in xwiki-platform, the XWiki Platform's generic wiki component that indexes pages, attachments, orphans and deleted items. An attacker with low-privileged access to the wiki who stores an attachment whose name contains JavaScript can have that script run in the browser of anyone who views the deleted attachments index, which requires user interaction and can affect the victim's session in another security scope.

Official description · CVE.org

The XWiki Platform Index UI is an Index of all pages, attachments, orphans and deleted pages and attachments for XWiki Platform, a generic wiki platform. Prior to versions 13.10.6 and 14.3, it's possible to store JavaScript which will be executed by anyone viewing the deleted attachments index with an attachment containing javascript in its name. This issue has been patched in XWiki 13.10.6 and 14.3. As a workaround, modify fix the vulnerability by editing the wiki page `XWiki.DeletedAttachments` with the object editor, open the `JavaScriptExtension` object and apply on the content the changes that can be found on the fix commit.

Breakdown
26.1 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 8 Sep 2022. No public exploit code or confirmed exploitation is recorded.

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.xwiki.platform:xwiki-platform-index-ui.

Mavenorg.xwiki.platform:xwiki-platform-index-uiGHSA-gjmq-x5x7-wc36

Upgrade to 14.3 or later

Set the version to 14.3 or later in your pom.xml or build.gradle.

The first fix for CVE-2022-36096. No other CVE tracked by Patchfirst affects this package.

Affected versions, by release line

If you runUpgrade to
14.0 up to 14.314.3
2.2-milestone-1 up to 13.10.613.10.6

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close