Patchfirst
CVE-2023-0286 High · 7.4 EPSS 69.3%

X.400 address type confusion in X.509 GeneralName

OpenSSL · OpenSSL

Official description · CVE.org

There is a type confusion vulnerability relating to X.400 address processing inside an X.509 GeneralName. X.400 addresses were parsed as an ASN1_STRING but the public structure definition for GENERAL_NAME incorrectly specified the type of the x400Address field as ASN1_TYPE. This field is subsequently interpreted by the OpenSSL function GENERAL_NAME_cmp as an ASN1_TYPE rather than an ASN1_STRING. When CRL checking is enabled (i.e. the application sets the X509_V_FLAG_CRL_CHECK flag), this vulnerability may allow an attacker to pass arbitrary pointers to a memcmp call, enabling them to read memory contents or enact a denial of service. In most cases, the attack requires the attacker to provide both the certificate chain and CRL, neither of which need to have a valid signature. If the attacker only controls one of these inputs, the other input must already contain an X.400 address as a CRL distribution point, which is uncommon. As such, this vulnerability is most likely to only affect applications which have implemented their own functionality for retrieving CRLs over a network.

Breakdown
28.1 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 8 Feb 2023. No public exploit code or confirmed exploitation is recorded.

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

2 packages in 2 ecosystems. Main package: openssl-src.

Upgrade to 300.0.12 or later

Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2022-0778, CVE-2022-3602, +1).

Cargocargo update -p openssl-src --precise 300.0.12

The first fix for CVE-2023-0286.

Affected versions, by release line

If you runUpgrade to
300.0.0 up to 300.0.12300.0.12
All versions before 111.25.0111.25.0

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (1)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • PyPIcryptography
    Affected: 0.8.1 up to 39.0.1Upgrade to 39.0.1 or later

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

21 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close