Patchfirst
CVE-2023-32315 KEVPublic exploit High · 7.5 EPSS >99.9%

Ignite Realtime Openfire Path Traversal Vulnerability

Ignite Realtime · Openfire

Summary

Openfire, the XMPP server from Ignite Realtime, contains a path traversal flaw in its administrative console's setup environment, which is web-based. An unauthenticated remote attacker, with no user interaction required, can use the unauthenticated setup environment on an already configured server to reach restricted administrative pages in the Admin Console.

Official description · NVD

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

Breakdown
82.1 / 100
Exploited
Yes, in CISA KEV
Reports
1
Tactics
4/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. How attackers get in

  2. What they do

  3. What can follow

First seen exploited 14 days after disclosure. Public exploit code (Metasploit) was available the same day.

  1. Named in a threat reportaquasec.com3 yrs before
  2. DisclosedPublic exploit codeMetasploitday 0
  3. First seen exploitedVulnCheck KEV evidence+14 days
  4. Added to CISA KEVEU database agrees+3 mo

CISA KEV listing is when exploitation was confirmed, not necessarily the first attack.

6 fixes in xmppserver over 6 years. The latest fix listed for xmppserver is 5.0.2.

Fixes in xmppserverMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 4.4.1CVE-2019-1548823 Aug 2019
  2. 4.4.2CVE-2019-2052818 Mar 2020
  3. 4.7.5CVE-2023-3231526 May 2023KEV
  4. 4.8.1CVE-2024-2542026 Mar 2024
  5. 4.8.1CVE-2024-2542126 Mar 2024
  6. 5.0.2CVE-2025-5915415 Sep 2025Latest listed

techniques

4 , grouped by in kill-chain order 4

PersistenceTA0003

Web Shell T1505.003
MITRE CTID mapping of the KEV entry · primary impact

CVE-2023-32315 is a path traversal bug in Openfire's administrative console that could be leveraged for remote code execution. Public reports have indicated that threat actors were exploiting this vulnerability to gain access to the Openfire plugins interface to create new admin console user accounts, install a malicious plugin, and gain access to a webshell.

Stealth

MITRE CTID mapping of the KEV entry · how it is exploited

DiscoveryTA0007

Domain Account T1087.002
MITRE CTID mapping of the KEV entry · follow-on activity

ImpactTA0040

MITRE CTID mapping of the KEV entry · follow-on activity

Detection

0 rules for this CVE · 110 general rules for its techniques

Rules for this CVE

0 that reference CVE-2023-32315 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

General rules for this CVE’s techniques

These detect the technique in general, not this specific vulnerability.

Indirect Command ExecutionT120241 general rules
Web ShellT1505.00335 general rules
Domain AccountT1087.00221 general rules
Resource HijackingT149613 general rules

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.igniterealtime.openfire:xmppserver.

Mavenorg.igniterealtime.openfire:xmppserverGHSA-gw42-f939-fhvm

Upgrade to 4.7.5 or later

Set the version to 4.7.5 or later in your pom.xml or build.gradle.

The first fix for CVE-2023-32315. No other CVE tracked by Patchfirst affects this package.

Affected versions, by release line

If you runUpgrade to
4.7.0 up to 4.7.54.7.5
3.10.0 up to 4.6.84.6.8

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Named in 1 threat report
1 reportAqua SecurityApr 2020

Reports are matched by finding the exact id CVE-2023-32315 in their text; nobody has reviewed the match. One passage is shown per report, at most 320 characters, linked to the original.

Also mentioned in 50 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

3 links, grouped by NVD tag (2 duplicates merged)
↑ ↓ chooseEnter openEsc close