Patchfirst
CVE-2023-40176 Critical · 9.1 EPSS 80.0%

SXSS in the user profile via the timezone displayer

xwiki · xwiki-platform

Summary

A stored cross-site scripting flaw exists in the time zone displayer of the user profile in xwiki-platform, the XWiki Platform generic wiki platform. An attacker who is any registered user can set a malicious payload as the time zone preference, bypassing the drop-down restriction via JavaScript or a crafted save request, and it executes unescaped when another user views the attacker's profile, which requires that user to visit the malicious profile.

Official description · CVE.org

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any registered user can exploit a stored XSS through their user profile by setting the payload as the value of the time zone user preference. Even though the time zone is selected from a drop down (no free text value) it can still be set from JavaScript (using the browser developer tools) or by calling the save URL on the user profile with the right query string. Once the time zone is set it is displayed without escaping which means the payload gets executed for any user that visits the malicious user profile, allowing the attacker to steal information and even gain more access rights (escalation to programming rights). This issue is present since version 4.1M2 when the time zone user preference was introduced. The issue has been fixed in XWiki 14.10.5 and 15.1RC1.

Breakdown
26.3 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 23 Aug 2023. No public exploit code or confirmed exploitation is recorded.

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.xwiki.platform:xwiki-platform-web-templates.

Mavenorg.xwiki.platform:xwiki-platform-web-templatesGHSA-h8cm-3v5f-rgp6

Upgrade to 14.10.5 or later

Set the version to 14.10.5 or later in your pom.xml or build.gradle.

The first fix for CVE-2023-40176. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
4.1-milestone-2 up to 14.10.514.10.5

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close