Upgrade to 15.5.4
Still affected on this line by CVE-2025-24893 (fixed in 15.10.11, a newer line).
Also affected, despite being newer: 15.6-rc-1 up to 15.10-rc-1.
Set the version to 15.5.4 or later in your pom.xml or build.gradle.
The first fix for CVE-2024-31984.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 15.6-rc-1 up to 15.10-rc-1 | 15.10.11first fix for this CVE: 15.10-rc-1 |
| 15.0-rc-1 up to 15.5.4 | 15.5.4 |
| 7.2-rc-1 up to 14.10.20 Still affected on this line by CVE-2025-24893 (fixed in 15.10.11, a newer line). | 14.10.20 |
“Up to” means the second version is the fix and is not affected.