Patchfirst
CVE-2024-36404 Public exploit Critical · 9.8 EPSS 76.1%

GeoTools Remote Code Execution (RCE) vulnerability in evaluating XPath expressions

geotools · geotools

Summary

GeoTools, an open source Java library for geospatial data, is vulnerable to remote code execution in its XPath expression evaluation functionality in versions prior to 31.2, 30.4, and 29.6. An unauthenticated remote attacker can exploit this without user interaction when an application uses that GeoTools functionality to evaluate XPath expressions supplied as user input, with the fix available in the listed patched versions and a workaround of removing the gt-complex jar at the cost of reduced functionality.

Official description · CVE.org

GeoTools is an open source Java library that provides tools for geospatial data. Prior to versions 31.2, 30.4, and 29.6, Remote Code Execution (RCE) is possible if an application uses certain GeoTools functionality to evaluate XPath expressions supplied by user input. Versions 31.2, 30.4, and 29.6 contain a fix for this issue. As a workaround, GeoTools can operate with reduced functionality by removing the `gt-complex` jar from one's application. As an example of the impact, application schema `datastore` would not function without the ability to use XPath expressions to query complex content. Alternatively, one may utilize a drop-in replacement GeoTools jar from SourceForge for versions 31.1, 30.3, 30.2, 29.2, 28.2, 27.5, 27.4, 26.7, 26.4, 25.2, and 24.0. These jars are for download only and are not available from maven central, intended to quickly provide a fix to affected applications.

Breakdown
31.8 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 2 Jul 2024. No public exploit code or confirmed exploitation is recorded.

See the family tree

2 related vulnerabilities in the same code over 1 day.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2024-36401OSGeo GeoServer GeoTools Eval Injection1 Jul 2024KEV
  2. relatedHigh

    Why these are linked:

    This CVECVE-2024-36404GeoTools Remote Code Execution (RCE) vulnerability in evaluating…2 Jul 2024

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

3 packages in 1 ecosystem. No single main package: each of these ships the affected code.

  • Mavenorg.geotools:gt-app-schema
    Affected: 31.0 up to 31.2; 30.0 up to 30.4; 29.0 up to 29.6; All versions before 28.6Upgrade to 31.2 or later (older lines: 30.4, 29.6, 28.6)
  • Mavenorg.geotools:gt-complex
    Affected: 31.0 up to 31.2; 30.0 up to 30.4; 29.0 up to 29.6; All versions before 28.6Upgrade to 31.2 or later (older lines: 30.4, 29.6, 28.6)
  • Mavenorg.geotools.xsd:gt-xsd-core
    Affected: 31.0 up to 31.2; 30.0 up to 30.4; 29.0 up to 29.6; All versions before 28.6Upgrade to 31.2 or later (older lines: 30.4, 29.6, 28.6)

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

16 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close