Patchfirst
CVE-2024-37014 Public exploit High · 8.8 EPSS 63.7%

Langflow through 0.6.19 allows remote code execution if untrusted users are able to reach the "POST /api/v1/custom_component" endpoint and provide a Python script.

Summary

Langflow through version 0.6.19 contains a flaw in its "POST /api/v1/custom_component" endpoint that permits remote code execution. An attacker who can reach that endpoint and submit a Python script can have it executed, provided they hold low-privilege credentials and need no user interaction.

Heading is the official description · CVE.org
Breakdown
71.0 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 2 years after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+2 yrs

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: langflow.

Upgrade to 1.10.3 or later

Fixes this CVE and 12 other known vulnerabilities in this package (CVE-2025-3248, CVE-2025-34291, +10).

pippip install "langflow>=1.10.3"

First fixed in 1.0.15 for CVE-2024-37014.

Affected versions, by release line

If you runUpgrade to
All versions before 1.0.151.10.3first fix for this CVE: 1.0.15
All versions before 1.0.0a31.10.3first fix for this CVE: 1.0.0a3

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close