Patchfirst
CVE-2024-45216 Public exploit Critical · 9.8 EPSS 92.7%

Apache Solr: Authentication bypass possible using a fake URL Path ending

Apache Software Foundation · Apache Solr

Summary

Apache Solr has an authentication bypass flaw in its PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is in use, affecting versions from 5.3.0 before 8.11.4 and from 9.0.0 before 9.7.0. An attacker with network access and no credentials or user interaction can skip authentication by appending a fake ending to the end of any Solr API URL path, which is stripped internally after authentication and before routing.

Official description · CVE.org

Improper Authentication vulnerability in Apache Solr. Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.

Breakdown
72.5 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

Public exploit code (PoC-in-GitHub) appeared 47 days after disclosure. No confirmed exploitation is recorded.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+47 days

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.solr:solr.

Mavenorg.apache.solr:solrGHSA-mjvf-4h88-6xm3

Upgrade to 9.7.0 or later

Set the version to 9.7.0 or later in your pom.xml or build.gradle.

The first fix for CVE-2024-45216. No other CVE tracked by Patchfirst affects this package.

Affected versions, by release line

If you runUpgrade to
9.0.0 up to 9.7.09.7.0
5.3.0 up to 8.11.48.11.4

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 1 community threat pulse (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close