Upgrade to 5.4.16
Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2025-30208, CVE-2025-31125).
Still affected on this line by CVE-2026-39365 (fixed in 6.4.2, a newer line).
npm install vite@5.4.16First fixed in 5.4.6 for CVE-2024-45811.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 5.4.0 up to 5.4.6 | 5.4.16first fix for this CVE: 5.4.6 |
| 5.3.0 up to 5.3.6 Still affected on this line by CVE-2025-30208 (fixed in 5.4.15, a newer line); CVE-2025-31125 (fixed in 5.4.16, a newer line); CVE-2026-39365 (fixed in 6.4.2, a newer line). | 5.3.6 |
| 5.2.0 up to 5.2.14 Still affected on this line by CVE-2025-30208 (fixed in 5.4.15, a newer line); CVE-2025-31125 (fixed in 5.4.16, a newer line); CVE-2026-39365 (fixed in 6.4.2, a newer line). | 5.2.14 |
| 5.0.0 up to 5.1.8 Still affected on this line by CVE-2025-30208 (fixed in 5.4.15, a newer line); CVE-2025-31125 (fixed in 5.4.16, a newer line); CVE-2026-39365 (fixed in 6.4.2, a newer line). | 5.1.8 |
| 4.0.0 up to 4.5.4 Still affected on this line by CVE-2026-39365 (fixed in 6.4.2, a newer line). | 4.5.11first fix for this CVE: 4.5.4 |
| All versions before 3.2.11 Still affected on this line by CVE-2025-30208 (fixed in 4.5.10, a newer line); CVE-2025-31125 (fixed in 4.5.11, a newer line); CVE-2026-39365 (fixed in 6.4.2, a newer line). | 3.2.11 |
“Up to” means the second version is the fix and is not affected.