Patchfirst
CVE-2025-27636 Public exploit Medium · 5.6 EPSS 97.1%

Apache Camel: Camel Message Header Injection via Improper Filtering

Apache Software Foundation · Apache Camel

Official description · CVE.org

Bypass/Injection vulnerability in Apache Camel components under particular conditions. This issue affects Apache Camel: from 4.10.0 through <= 4.10.1, from 4.8.0 through <= 4.8.4, from 3.10.0 through <= 3.22.3. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, to call another method on the bean, than was coded in the application. In the camel-jms component, then a malicious header can be used to send the message to another queue (on the same broker) than was coded in the application. This could also be seen by using the camel-exec component The attacker would need to inject custom headers, such as HTTP protocols. So if you have Camel applications that are directly connected to the internet via HTTP, then an attacker could include malicious HTTP headers in the HTTP requests that are send to the Camel application. All the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow, camel-platform-http, and camel-netty-http would be vulnerable out of the box. In these conditions an attacker could be able to forge a Camel header name and make the bean component invoking other methods in the same bean. In terms of usage of the default header filter strategy the list of components using that is: * camel-activemq * camel-activemq6 * camel-amqp * camel-aws2-sqs * camel-azure-servicebus * camel-cxf-rest * camel-cxf-soap * camel-http * camel-jetty * camel-jms * camel-kafka * camel-knative * camel-mail * camel-nats * camel-netty-http * camel-platform-http * camel-rest * camel-sjms * camel-spring-rabbitmq * camel-stomp * camel-tahu * camel-undertow * camel-xmpp The vulnerability arises due to a bug in the default filtering mechanism that only blocks headers starting with "Camel", "camel", or "org.apache.camel.".  Mitigation: You can easily work around this in your Camel applications by removing the headers in your Camel routes. There are many ways of doing this, also globally or per route. This means you could use the removeHeaders EIP, to filter out anything like "cAmel, cAMEL" etc, or in general everything not starting with "Camel", "camel" or "org.apache.camel.".

Breakdown
65.8 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 29 days after disclosure. Public exploit code (PoC-in-GitHub) was available the same day.

  1. DisclosedPublic exploit codePoC-in-GitHubday 0
  2. First seen exploitedVulnCheck KEV evidence+29 days

3 related vulnerabilities in the same code over 14 months.

Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. This CVECVE-2025-27636Camel: Camel Message Header Injection via Improper Filtering9 Mar 2025
  2. relatedLow

    Why these are linked:

    • Stated in the CVE textThis CVE is related to the CVE-2025-27636: while they have the same root cause and are fixed with the same fix, CVE-2025-27636 was assumed to only be exploitable if an attacker could add malicious HTTP headers, while we have now determine…
    CVE-2025-29891Camel: Camel Message Header Injection through request parameters12 Mar 2025
  3. same family
    CVE-2026-40453Camel JMS, Apache Camel CoAP, Apache Camel Google PubSub…27 Apr 2026

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.camel:camel-support.

Mavenorg.apache.camel:camel-supportGHSA-2c2h-2855-mf97

Upgrade to 4.10.2 or later

Fixes this CVE and 1 other known vulnerability in this package (CVE-2025-29891).

Set the version to 4.10.2 or later in your pom.xml or build.gradle.

The first fix for CVE-2025-27636.

Affected versions, by release line

If you runUpgrade to
4.9.0 up to 4.10.24.10.2
4.0.0-M1 up to 4.8.54.8.5
3.10.0 up to 3.22.43.22.4

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

6 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close