Upgrade to 16.10.9 or later
Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2025-29925, CVE-2025-46554, +1).
Set the version to 16.10.9 or later in your pom.xml or build.gradle.
First fixed in 16.10.1 for CVE-2025-32969.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 16.5.0-rc-1 up to 16.10.1 | 16.10.9first fix for this CVE: 16.10.1 |
| 16.0.0-rc-1 up to 16.4.6 Still affected on this line by CVE-2025-52472 (fixed in 16.10.9, a newer line). | 16.4.6 |
| 1.8 up to 15.10.16 Still affected on this line by CVE-2025-52472 (fixed in 16.10.9, a newer line). | 15.10.16 |
“Up to” means the second version is the fix and is not affected.