Patchfirst
CVE-2026-114612 Critical · 9.9 EPSS 0.3%

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format

BerriAI · litellm

Summary

LiteLLM's proxy server, an AI Gateway for calling LLM APIs, reuses a single cryptographic context for both at-rest secrets and session tokens, so an authenticated internal user can craft metadata that yields a forged administrator credential through the API-key flow. An attacker with low-privilege authenticated access and no user interaction can replay that forged credential as a bearer token to gain administrative access and run arbitrary commands via the MCP stdio endpoint, with versions 1.87.0 through 1.90.x additionally requiring EXPERIMENTAL_UI_LOGIN to be enabled.

Official description · NVD

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through 1.90.x require EXPERIMENTAL_UI_LOGIN to be enabled, while versions after 1.91.0 are exploitable in the default configuration. This issue was fixed in LiteLLM 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2.

Breakdown
13.8 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 22 Oct 2026. No public exploit code or confirmed exploitation is recorded.

2 related vulnerabilities in the same code over 2 years. The latest fix listed for litellm is 1.104.0rc2.

Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2024-6587SSRF in berriai/litellm13 Sep 2024
  2. relatedMedium

    Why these are linked:

    This CVECVE-2026-114612LiteLLM is a proxy server (AI Gateway) to call LLM APIs in…22 Oct 2026

Fixes in litellmPyPI package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.84.0CVE-2026-4946822 Jun 2026
  2. 1.84.0CVE-2026-598228 Jul 2026KEV
  3. 1.96.2CVE-2026-843772 Sep 2026
  4. 1.104.0rc2CVE-2026-11461222 Oct 2026Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: litellm.

Upgrade to 1.103.1

Also affected, despite being newer: 1.104.0rc1 up to 1.104.0rc2.

pippip install "litellm>=1.103.1"

The first fix for CVE-2026-114612.

Affected versions, by release line

If you runUpgrade to
1.104.0rc1 up to 1.104.0rc21.104.0rc2
1.103.0 up to 1.103.11.103.1
1.102.0 up to 1.102.21.102.2
1.101.0 up to 1.101.31.101.3
1.91.0 up to 1.100.41.100.4

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 6 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

11 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close