Upgrade to 4.8.2 or later
Set the version to 4.8.2 or later in your composer.json.
The first fix for CVE-2018-12613.
Affected versions
| If you run | Upgrade to |
|---|---|
| 4.8 up to 4.8.2 | 4.8.2 |
“Up to” means the second version is the fix and is not affected.
An issue in phpMyAdmin 4.8.x before 4.8.2 lets an attacker include and potentially execute files on the server, because the code that redirects and loads pages inside phpMyAdmin improperly checks whitelisted pages. Exploitation normally requires an authenticated session, but the flaw can be reached without authentication when the configuration sets ServerDefault to 0 (bypassing the login requirement), and it can lead to arbitrary code execution when AllowArbitraryServer is enabled and the attacker controls a host they can specify.
An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).
First seen exploited 4 years after disclosure. Public exploit code (Metasploit) was available 2 days before disclosure.
7 fixes in phpmyadmin/phpmyadmin over 10 months. The latest fix listed for phpmyadmin/phpmyadmin is 4.8.4.
No high- or medium-confidence techniques. The 1 available link are lower confidence and listed below.
These come from early or generic mappings, text matching, or contradict this CVE’s details (for example a public-facing technique on a bug that needs a user to open a file). Shown for completeness.
1 package in 1 ecosystem. Main package: phpmyadmin/phpmyadmin.
Upgrade to 4.8.2 or later
Set the version to 4.8.2 or later in your composer.json.
The first fix for CVE-2018-12613.
| If you run | Upgrade to |
|---|---|
| 4.8 up to 4.8.2 | 4.8.2 |
“Up to” means the second version is the fix and is not affected.
Reports are matched by finding the exact id CVE-2018-12613 in their text; nobody has reviewed the match. One passage is shown per report, at most 320 characters, linked to the original.
…of Sophos SG UTMCVE-2021-42013ApacheCVE-2022-31137Roxy-WICVE-2022-33891Apache SparkZSL-2022-5717MiniDVBLinuxSince the release of Zerobot 1.1, the malware operators have removed CVE-2018-12613, a phpMyAdmin vulnerability that could allow threat actors to view or execute…
Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.