Upgrade to 7.1.0
Fixes this CVE and 1 other known vulnerability in this package (CVE-2017-12629).
Still affected on this line by CVE-2019-0193 (fixed in 8.2.0, a newer line); CVE-2019-17558 (fixed in 8.4.0, a newer line); CVE-2020-13957 (fixed in 8.6.3, a newer line); CVE-2023-50386 (fixed in 8.11.3, a newer line).
Set the version to 7.1.0 or later in your pom.xml or build.gradle.
First fixed in 7.0.0 for CVE-2019-0192.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 6.0.0 up to 7.0.0 | 7.1.0first fix for this CVE: 7.0.0 |
| 5.0.0 up to 7.0.0 Still affected on this line by CVE-2017-12629 (fixed in 7.1.0, a newer line); CVE-2019-0193 (fixed in 8.2.0, a newer line); CVE-2019-17558 (fixed in 8.4.0, a newer line); CVE-2020-13957 (fixed in 8.6.3, a newer line); CVE-2023-50386 (fixed in 8.11.3, a newer line). | 7.0.0 |
“Up to” means the second version is the fix and is not affected.