Patchfirst
CVE-2020-15199 Medium · 5.9 EPSS 0.8%

Denial of Service in Tensorflow

tensorflow · tensorflow

Official description · CVE.org

In Tensorflow before version 2.3.1, the `RaggedCountSparseOutput` does not validate that the input arguments form a valid ragged tensor. In particular, there is no validation that the `splits` tensor has the minimum required number of elements. Code uses this quantity to initialize a different data structure. Since `BatchedMap` is equivalent to a vector, it needs to have at least one element to not be `nullptr`. If user passes a `splits` tensor that is empty or has exactly one element, we get a `SIGABRT` signal raised by the operating system. The issue is patched in commit 3cbb917b4714766030b28eba9fb41bb97ce9ee02 and is released in TensorFlow version 2.3.1.

Breakdown
15.5 / 100
Exploited
Not confirmed
Reports
0
Tactics
3/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. What they do

Disclosed on 25 Sep 2020. No public exploit code or confirmed exploitation is recorded.

techniques

2 , grouped by in kill-chain order 2

ExecutionTA0002

Hijack Execution Flow T1574 also Stealth
MITRE CTID mapping of the CVE · primary impact

ImpactTA0040

MITRE CTID mapping of the CVE · primary impact

Detection

0 rules for this CVE · 11 general rules for its techniques

Rules for this CVE

0 that reference CVE-2020-15199 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

General rules for this CVE’s techniques

These detect the technique in general, not this specific vulnerability.

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

3 packages in 1 ecosystem. Main package: tensorflow.

Upgrade to 2.3.1 or later

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2020-15208, CVE-2020-15211).

pippip install "tensorflow>=2.3.1"

The first fix for CVE-2020-15199.

Affected versions

If you runUpgrade to
All versions before 2.3.12.3.1

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (2)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • PyPItensorflow-cpu
    Affected: All versions before 2.3.1Upgrade to 2.3.1 or later
  • PyPItensorflow-gpu
    Affected: All versions before 2.3.1Upgrade to 2.3.1 or later

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close