Patchfirst
CVE-2022-1429 High · 7.2 EPSS 63.9%

SQL injection in GridHelperService.php in pimcore/pimcore

pimcore · pimcore/pimcore

Summary

The SQL injection flaw lives in the GridHelperService.php component of the pimcore/pimcore product from pimcore, in versions prior to 10.3.6, where improper neutralisation of special elements in SQL commands allows query manipulation. An attacker who holds high-privilege credentials on a network-reachable instance can, with no user interaction required, exploit it to read or steal data, with the vulnerability also capable of affecting integrity and availability.

Official description · CVE.org

SQL injection in GridHelperService.php in GitHub repository pimcore/pimcore prior to 10.3.6. This vulnerability is capable of steal the data

Breakdown
24.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 22 Apr 2022. No public exploit code or confirmed exploitation is recorded.

7 fixes in pimcore/pimcore over 14 months. The latest fix listed for pimcore/pimcore is 10.4.0.

Fixes in pimcore/pimcorePackagist package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 10.3.3CVE-2023-273016 May 2023
  2. 10.3.5CVE-2022-12198 Apr 2022
  3. 10.3.5CVE-2022-133913 Apr 2022
  4. 10.3.6CVE-2022-142922 Apr 2022
  5. 10.4.0CVE-2022-089315 Mar 2022
  6. 10.4.0CVE-2022-070416 Mar 2022
  7. 10.4.0CVE-2022-070516 Mar 2022Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: pimcore/pimcore.

Packagistpimcore/pimcoreGHSA-2v7p-f4qm-r5pc

Upgrade to 10.5.19 or later

Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2019-10867, CVE-2022-0832, +1).

Set the version to 10.5.19 or later in your composer.json.

First fixed in 10.3.6 for CVE-2022-1429.

Affected versions

If you runUpgrade to
All versions before 10.3.610.5.19first fix for this CVE: 10.3.6

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close