Upgrade to 10.0.22
Fixes this CVE and 4 other known vulnerabilities in this package (CVE-2020-13934, CVE-2020-13935, +2).
Also affected, despite being newer: 10.1.0-M1 up to 10.1.0-M17.
Set the version to 10.0.22 or later in your pom.xml or build.gradle.
The first fix for CVE-2022-34305.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 10.1.0-M1 up to 10.1.0-M17 | 10.1.45first fix for this CVE: 10.1.0-M17 |
| 10.0.0-M1 up to 10.0.22 | 10.0.22 |
| 9.0.30 up to 9.0.65 | 9.0.109first fix for this CVE: 9.0.65 |
| 8.5.50 up to 8.5.82 Still affected on this line by CVE-2025-55752 (no fix published). | 8.5.82 |
“Up to” means the second version is the fix and is not affected.