Upgrade to 15.5.4
Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2024-31465, CVE-2024-31982).
Also affected, despite being newer: 15.6-rc-1 up to 15.7-rc-1.
Set the version to 15.5.4 or later in your pom.xml or build.gradle.
First fixed in 15.5.2 for CVE-2023-50721.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 15.6-rc-1 up to 15.7-rc-1 | 15.10-rc-1first fix for this CVE: 15.7-rc-1 |
| 15.0-rc-1 up to 15.5.2 | 15.5.4first fix for this CVE: 15.5.2 |
| 4.5-rc-1 up to 14.10.15 | 14.10.20first fix for this CVE: 14.10.15 |
“Up to” means the second version is the fix and is not affected.