Upgrade to 15.5.4
Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2023-50721, CVE-2024-31982).
Also affected, despite being newer: 15.6-rc-1 up to 15.10-rc-1.
Set the version to 15.5.4 or later in your pom.xml or build.gradle.
The first fix for CVE-2024-31465.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 15.6-rc-1 up to 15.10-rc-1 | 15.10-rc-1 |
| 15.0-rc-1 up to 15.5.4 | 15.5.4 |
| 5.2-milestone-2 up to 14.10.20 | 14.10.20 |
“Up to” means the second version is the fix and is not affected.