Patchfirst
CVE-2024-32114 Public exploit High · 8.5 EPSS 7.1%

Apache ActiveMQ: Jolokia and REST API were not secured with default configuration

Apache Software Foundation · Apache ActiveMQ

Official description · CVE.org

In Apache ActiveMQ 6.x, the default configuration doesn't secure the API web context (where the Jolokia JMX REST API and the Message REST API are located). It means that anyone can use these layers without any required authentication. Potentially, anyone can interact with the broker (using Jolokia JMX REST API) and/or produce/consume messages or purge/delete destinations (using the Message REST API). To mitigate, users can update the default conf/jetty.xml configuration file to add authentication requirement: <bean id="securityConstraintMapping" class="org.eclipse.jetty.security.ConstraintMapping">   <property name="constraint" ref="securityConstraint" />   <property name="pathSpec" value="/" /> </bean> Or we encourage users to upgrade to Apache ActiveMQ 6.1.2 where the default configuration has been updated with authentication by default.

Breakdown
70.5 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

Public exploit code (PoC-in-GitHub) appeared 24 months after disclosure. No confirmed exploitation is recorded.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+24 mo

6 fixes in apache-activemq over 13 years. The latest fix listed for apache-activemq is 6.2.4.

Fixes in apache-activemqMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 5.8.0CVE-2012-655121 Apr 2013
  2. 5.17.4CVE-2022-4167828 Nov 2023
  3. 6.1.2CVE-2024-321142 May 2024
  4. 6.2.1CVE-2025-661684 Mar 2026
  5. 6.2.4CVE-2026-400469 Apr 2026
  6. 6.2.4CVE-2026-3930410 Apr 2026Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.activemq:apache-activemq.

Mavenorg.apache.activemq:apache-activemqGHSA-gj5m-m88j-v7c3

Upgrade to 6.2.5 or later

Fixes this CVE and 1 other known vulnerability in this package (CVE-2026-40466).

Set the version to 6.2.5 or later in your pom.xml or build.gradle.

First fixed in 6.1.2 for CVE-2024-32114.

Affected versions

If you runUpgrade to
6.0.0 up to 6.1.26.2.5first fix for this CVE: 6.1.2

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 1 community threat pulse (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close