Patchfirst
CVE-2024-47167 Medium · 6.9 EPSS 0.5%

SSRF in the path parameter of /queue/join in Gradio

gradio-app · gradio

Official description · CVE.org

Gradio is an open-source Python package designed for quick prototyping. This vulnerability relates to **Server-Side Request Forgery (SSRF)** in the `/queue/join` endpoint. Gradio’s `async_save_url_to_cache` function allows attackers to force the Gradio server to send HTTP requests to user-controlled URLs. This could enable attackers to target internal servers or services within a local network and possibly exfiltrate data or cause unwanted internal requests. Additionally, the content from these URLs is stored locally, making it easier for attackers to upload potentially malicious files to the server. This impacts users deploying Gradio servers that use components like the Video component which involve URL fetching. Users are advised to upgrade to `gradio>=5` to address this issue. As a workaround, users can disable or heavily restrict URL-based inputs in their Gradio applications to trusted domains only. Additionally, implementing stricter URL validation (such as allowinglist-based validation) and ensuring that local or internal network addresses cannot be requested via the `/queue/join` endpoint can help mitigate the risk of SSRF attacks.

Breakdown
58.1 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 2 years after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+2 yrs

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: gradio.

Upgrade to 5.0.0

Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2024-1561, CVE-2024-1728, +1).

Still affected on this line by CVE-2026-28414 (fixed in 6.7.0, a newer line).

pippip install "gradio>=5.0.0"

The first fix for CVE-2024-47167.

Affected versions

If you runUpgrade to
All versions before 5.0.05.0.0

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close