Upgrade to 2.5.33
Fixes this CVE and 7 other known vulnerabilities in this package (CVE-2017-12611, CVE-2017-5638, +5).
Still affected on this line by CVE-2024-53677 (fixed in 6.4.0, a newer line); CVE-2025-68493 (no fix published).
Set the version to 2.5.33 or later in your pom.xml or build.gradle.
First fixed in 2.5.17 for CVE-2018-11776.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 2.5 up to 2.5.17 | 2.5.33first fix for this CVE: 2.5.17 |
| 2.0.4 up to 2.3.35 Still affected on this line by CVE-2019-0230 (fixed in 2.5.22, a newer line); CVE-2019-0233 (fixed in 2.5.22, a newer line); CVE-2020-17530 (fixed in 2.5.26, a newer line); CVE-2021-31805 (fixed in 2.5.30, a newer line); CVE-2023-50164 (fixed in 2.5.33, a newer line); CVE-2024-53677 (fixed in 6.4.0, a newer line); CVE-2025-68493 (no fix published). | 2.3.35 |
“Up to” means the second version is the fix and is not affected.